Skip to main content

RealFlight Homepage

Are the Expansion Packs compatible with RealFlight Basic?

The RealFlight Expansion Packs are not compatible with RealFlight Basic.

Expansion Packs 1 through 4 are compatible with RealFlight G3 and above. Expansion Packs 5 and 6 are compatible with RealFlight G4 and above.

Return to Article List